
Tutorial 1 
 

Goals:  

- Introduction to Maya and Unity 

- Creation of Pagoda 

 

Load up Maya 

 

 

Keyboard Shortcuts 
Manipulating elements in Maya is a combination of Keyboard and Mouse.  Below are the primary 

keyboard keys: 

 

 



 

The main keys used are: 

Q – Select 

W – Move 

E – Rotate 

R – Scale 

Spacebar – Change view (4 panels to single view panel)  

In addition to one key shortcuts there are combination keys which use Ctrl or Shift plus a key to 

achieve differing results; primary combinations are: 

Edit Operations 

Ctrl (or Cmd) + C Copy 

Ctrl (or Cmd) + X Cut 

Ctrl + D Duplicate 

Ctrl + Shift + D Duplicate Special 

Shift + D Duplicate with Transform 

Ctrl + G Group 

P Parent 

Ctrl (or Cmd) + V Paste 

Shift + Z Redo 

G Repeat 

Shift + G Repeat command at mouse position 

Z Undo (also Ctrl+z/+z) 

Shift + P Unparent 

Ctrl + R Create file reference 



Ctrl + Q Exit 

Ctrl + N New Scene 

Ctrl + O Open Scene 

Ctrl + S Save Scene 

Ctrl + Shift + S Save Scene As 

 

All key combinations can be located here: https://www.autodesk.com/shortcuts/maya# 

Mouse Manipulation 
Mouse manipulation is enhanced due to a combination of key presses at the same time as mouse 

click events. 

- Left Click:  Object Select 

- Left Click + Alt: Rotate around object 

 

- Right Click: Menu pop up 

- Right Click + Alt: Zoom in/Out 

 

- Scroll Wheel: Zoom in/Out 

- Scroll Wheel + Alt: Pan screen 

 

Interface 
The Maya interface looks like the following: 

 

https://www.autodesk.com/shortcuts/maya


There is a lot going on, but we can simplify the interface down to areas to ease up the learning 

curve. Primary areas of concern are: 

Menu: 

 

Shelf: 

 

Tool Box: 

 

Channel Box: 

 

View Panel: 

 or  

 

 

 

 

 

 

 

As you can see, the view panel comes in two base layouts, a single view or 4 views; front, top, side 

and perspective views. 



 The shelf contains the primary objects that get placed and manipulated in the view panels. It’s 

possible to create a custom shelf, this allows for the focus on the primary objects and tools you will 

use.  Basically, elements are selected from the menu system and added to the shelf. This id done by 

using Ctrl+Shift+ left click on the icon from the menu whilst the custom shelf is displayed. 

 

Creating a Custom shelf 
Click on custom in the shelf area 

 

Next we add some objects, in this case we will add the following polygons Sphere, Cube and 

Cylinder.  From the Menu->Create->Polygon Primitives section run the mouse over the icon next to 

the words Sphere, Cube and Cylinder.  

 

Hold down Ctrl+Shift keys and then click on the icons, this should change the blank custom shelf to 

contain the following: 

 

In addition to adding objects to the shelf, we can also include tools.  Add the following tools to the 

custom shelf: 

- Mesh Tools-> Insert Edge Loop 

- Edit Mesh -> Extrude 

- Edit Mesh->Duplicate 

- Mesh->Boolean->Union 

- Mesh->Boolean-> Difference 

- Mesh->Boolean-> Intersection 



This should give you the following Custom Shelf: 

 

 

Now that we have a custom shelf, let’s build an object. 

 

Build Object: Pagoda 
Building in Maya is a lot like building with lego pieces, you visualise the final object that you want to 

create and break it into it’s simpler objects, you then create these objects and then put the elements 

together. 

 

 

 

 

Looking at the above structure, you can see that it consists of multiple shapes, there are half 

spheres, multiple octagons, multiple cylinders and multiple squares.  As we already have a custom 

shelf with these items, let’s start by creating a base cylinder.  

 



Pagoda Base: 

Click on Cylinder 

 Produces  in the perspective view, now we need to 

manipulate this to make a base octagon. To do this on the channel box area there are a few side 

menus, select attribute editor. 

 

This swaps channel box for the attribute editor which showcases a lot of differing information. 

 

Let’s name our object so we can locate it later if needed. To do this, click on pCylinder1 



 

And change the name to baseFloor for reference 

 

As you can see, it names other aspects of the object. Now we can change the elements needed to 

create the octagon base.  

Click on polyCylinder1 

 

From here, we can change the base numbers of the cylinder object. Modify the following attributes: 

- Radius – 2  

- Height – 0.1 

- Subdivision Axis – 8 

You should see the following: 



 

With these changes, applied the cylinder has now become a thin octagon which is perfect for the 

base of the pagoda. 

 

Now that we have the base we need to make a duplicate of it.  Click on the object, so you can see 

the faces of the object, then do a Ctrl+D to duplicate. Push W to swap from select to move and then, 

use the arrow to move the new shape higher so you can see it. You should have the following: 

 

From here, we move to the attribute editor to make some more changes. First off, we will change 

the name; baseFloor1 to firstStep 



 

 

Then in the transform attributes drop the scale from 1 to 0.9. Use the Alt + Left click to rotate your 

view around the object to see what you have done. 

To make viewing multiple objects easier, in the view menu settings – under the shelf, go to shading -

>Wireframe on Shaded 

  

This will let you view the objects easier. 

 



Now we want to move the objects together, as you can see we have a gap between them. The 

easiest way is to jump out of perspective view and move to front or side view. In this case we will 

use side view. 

To do this, click on your firstStep Object and push the spacebar. You should be presented with the 

following screen: 

 

Click on the side view and push the spacebar, this will make the sideview the main window 

 

Next scroll in using the mouse wheel, push Q for select and then click on the firstStep object, then 

push W. In this view you will see that the movement tool only allows for up/down and left/right this 

allows for us to be precise when move objects around on the screen. Using the mouse, drag the 

firstStep object onto the baseFloor object. 



 

 

 

From here, we will go back to perspective view. Spacebar out to the 4 views and then click on 

perspective and spacebar to make that the primary window. As you can see from the merge that we 

just did, the two elements have blended together well. 

 

 

Now we will create the columns for the pagoda. To do this create a cylinder and drag it off to the 

side of the base. 



 

As you can see we will need to manipulate the cylinders dimensions as well. First off, we will change 

its name. Go to Attribute Editor and then pCylinder1, change the name to columnBase. 

 

Next, click on polyCylinder2 and change the Radius, Height and Subdivision Axis. 

 

To the following 

- Radius – 0.1 

- Height – 2 

- Subdivision Axis – 5 



 

This should provide a single column that looks like this 

 

From here, we will want to place columns in the corners of the first Step object, so it has a structure 

that we can put the roof on. To do this, go to Side view and place the base of the column to the top 

of the first step. 

  

Next, we go to top view, to see where on the base we have placed it. 

 



On first viewing, it looks as though there is nothing there, before we turn on the wiring, let’s have a 

quick look at the outliner panel. 

Located in the tools pane, the bottom icon loads up the outliner panel. Click on this and you will see 

the following. 

 

As you can see, the outliner panel lists all the elements in the scene, ranging from the views that we 

can see, to the objects and light set. If you click on the names of our objects you will see them 

highlight in the view panel. 

 

If you have a lot of objects in a scene, this is a good way to keep track of them. In this case, as we 

want to see all of the objects in this view, close the outliner panel (click on the icon) and then go into 

shading-> wireframe on shaded. This will show the following in top view. 



 

From here, we can move the column into a point on the octagon and then create multiple columns 

and drag them into the corners. To make it easier, we will use Ctrl + D to duplicate the columns and 

then use the mouse to position them. You should see the following 

 

Next swap over to perspective view to see how things are going. 

 

Now that we have a base, we can add a roof structure. Create a sphere and drag it to the side of our 

base structure. 



 

Go to the attribute Editor and change the name to mainRoof 

 

 

Now go to polyShpere1 and modify the attributes of Radius, Subdivision Axis and subdivision Height 

 

 

- Radius – 2.1 

- Subdivision Axis – 8 

- Subdivision Height – 20 

 



 

This will give a large sphere, of which we will now cut in half. Go to the Side View 

  

From here, select the sphere and then right click. This will give you the following menu pop up 

 

From here select Face. 



The 4 main elements of this menu that will primarily be used are Object Mode, Vertex, Face and 

Edge. A vertex is a singular point of an object, an Edge is a line between two Vertex and a Face is a 

whole object between Vertex’s. Object Mode selects the entire object. 

Vertex 

 

Edge 

 

Face 

 

 

Now that face has been selected, hold down the shift key and highlight the bottom half of the 

sphere. 

 

Push the delete key and you should see the following 

 

From here we can position this to the top of our base. You might need to go to top view to centre it 

correctly. 



 

Now, we can use the attribute editor to change the scale of the sphere. Select the object and then 

go to the mainRoof tab 

 

From here, change the Y scale from 1 to 0.6 

 

You should see the following 



 

Now we can make more elements appear by adding additional shapes which in turn improves the 

current design. 

Now we add a Torus shape, we didn’t add this to the custom shelf to start with, so we can add it 

now. Go to create->polygon primitives and then hold down Ctrl + Shift when you click on the Torus 

Icon. Your shelf should now look like this: 

 

Now, click on the new Torus button, you should see the following 

 

It doesn’t look like that’s what we want, but we are going to make some changes to shape. To start 

with, go to the attribute editor and change the name from pTourus1 to overHang 

 



 

Now go to the polyTorus1 tab 

 

From here we can make a few adjustments. 

- Radius – 2 

- Subdivision Axis – 8 

 

Next, we go back to the overhang tab and change the Y scale from 1 to 0.2 

 



 

This should give you the following changes in the view 

 

From here, go to the side view and drag the overhang object up to the base of the mainRoof Object 

 

Jump back to perspective view and it now looks like this 

 

From here, the overHang object looks a little large, so we can shrink it by changing the Radius from 2 

down to 1.9. This is in the polyTorus1 section of the attribute editor 



 

Next, we add some torus shapes to the columns to give them a little bit of style. Click the Torus icon 

in the custom shelf. 

Name this Torus shape from pTorus1 to baseColumnTorus 

 

 

From here we need to shrink and position the torus, from the transform attributes, change the scale 

from 1 to 0.2 on all axis 

 



 

From here swap from perspective view to top view to see the object. 

 

As you can see, we can’t locate our object as it is underneath other objects. Because the object is 

underneath our roof structures, we need to hide these objects to be able to view these elements. To 

start with this open the outliner panel. 

 

Highlight the mainRoof and overHang objects, then do Ctrl + H. This hides those objects 

 



Even though they are hidden we still can’t see the baseColumnTorus, this is because it is within the 

floor objects, in the outliner panel, select baseColumnTorus and then position it around a column.  

Get the centre point of the torus onto the column. 

 

From here, go to the perspective view and raise the torus so it can be viewed easily. As you can see, 

it easily surrounds the column, so we need to change the radius of it. 

 

Select the torus and then in the attribute editor, locate the polyTorus2 tab and drop the radius from 

1 to 0.6. 

 

This makes the following change to the view 

 

From here, duplicate this object and drag it up the column. 



 

From here, go to the outliner panel, select both mainRoof and OverHang and then push Shift+H. This 

will unhide the roof section. 

 

 

Now, we move the top torus up to make it look better. 



 

Overall, we hide a little over half of the torus in the overHang. Now, we duplicate this style on each 

column. Repeat each of the steps to position the torus for each column. Start with hiding the roof 

objects. 

You should end up with it looking like this: 

 

Now we will add a peak to the top of the pagoda. 

From the Create menu, add a Cone to the custom shelf. It should look like this once done 

 

Once done, click on cone, in the attribute editor, change the name from pCone1 to roofSpike 



 

 

From the side view, move the roofSpike object to the top of the mainRoof object 

 

Our cone is a little big, so we will now scale it down in size and shape it. Jump back to perspective 

view and go into the roofSpikes attributes. 

Modify the scale from 1/1/1 to 0.1/0.7/0.1 

 

This shrinks our roofSpike down. So it should look like this 



 

Though it is still too rounded for our design, so we will go to the polyCone1 tab and change the 

following 

- Radius – 0.6 

- Subdivision Axis – 8 

This shrinks the roofSpike down a bit more, from here go to sideview and position the roofSpike on 

the top of the dome. It should look like this: 

 

Now we add a torus to the spike to allow it to blend into the roof better. Click on the torus icon and 

then drag the new torus to the top of the mainRoof object. 

 

As before, the torus is too large, so we need to shrink it down. Go to the attribute editor, then 

change the name from pTorus1 to roofSpikeLink 



 

 

Now, in the transform attributes, drop the scale from 1/1/1 to 0.2/0.1/0.2 

 

This creates the following change 

 

Next, we go into the polyTorus3 tab and make the following changes 

- Radius – 0.6 

- Subdivision Axis – 8 

This creates 



 

From here, using the move tool, drop the torus into the roof, this should give you the following 

 

This will give you an overall pagoda structure of: 

 

From here, save your work.  You can add additional elements to the scene as desired. 

 



Now that you have completed the step by step for the pagoda, break down and design the following 

items: 

Park Bench: 

 or  

BBQ: 

 or  

Focus on the larger elements of the above items, break them into cubes and other primatives 

objects to construct. 

 

 

 


