Game Design — Unity Workshop
Activity 2

Goals:

- Creation of small world
- Creation of character
- Scripting of player movement and camera following

Load up unity

. Unity 2017.1.0p5 (64-bit)
E Report a Problem with Unity

] o
Unity Documentation

Unity Release Notes

Build Object: Mini World and basic Chase Cam

Aim: multi-level flat spheres to move the players object along.

To start with right-click in the hierarchy panel and create a plane

= Hierarchy | &=
Create ~ arAll
v & tutorial2* .=
Main Camera |
Directional Light

Copy
Paste
Rename
Duplicate
Delete
Create Empty
3D Object > Cube
2D Object > Sphere
Effects > Capsule
Light > Cylinder
Audio > Plane
Video > Quad

>
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Next, go to the inspector panel and reset the position from the cog icon.

© Inspector  [Serviess e
W Plane || Static =
Tag | Untagged +| Layer | Default ¢
¥ .~ Transform W &
Position X 1.988408 Reset
Rotation X0 |
Srala wi1 Move to Front

Once this is done, change the name of the plane to BaseLand and modify the scale of the object to
match the following

© Inspector  [ISERviseS eS|

¥ BaselLand | ] static ¥

Tag | Untagged ¢ | Layer | Default |

¥ .~ Transform -
Position X0 'Y 0 |Z 0 |
Rotation X0 Yo 1z/o |
Scale X 20 Y1 |Z 20 |

You should see the following in the scene view

Next, we will create a material and apply it to the BaseLand object.

Right click in the Assets panel and create a folder called Materials and one called Scripts



Open Scene Additive
Import New Asset...
Import Package >
Export Package...

Find References In Scene

Select Dependencies

Refresh Ctrl+R
Reimport

Reimport All

Run AP| Updater...

Open C# Project

You should end up with the following

@ Project

Name it groundColour and then in the inspector panel, click on the colour selector and assign a

colour to the material.

Open Scene Additive
Import New Asset...
Import Package
Export Package...

Find References In Scene

Select Dependencies

Refresh Ctri+R
Reimport
Reimport All
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Assets » Materials

© Inspector

groundColour &,
Shader

In this case, the rgba format is
R:0

G: 189

B: 72

A: 255

You can use any colour you like for this part of the tutorial.

Next drag the colour on BaselLand object and you should see the following in the scene view.



Next we are going to add a few more levels. Right click on BaseLand in the hierarchy pane and create
a new plane. Two things will happen, one a new plane with the same attributes as BaseLand is
created in the exact same position and two; the new object is now a child of BaselLand.

This is the introduction to grouping, with elements called Parents and Children. The children will
inherent the Parents attributes, but not assigned materials.

Now we rename and move the new plane, in the Inspector Panel change the name of plane to level-
1 and move its position to 0/-20/10

© Inspector [ Services s

& [Plane | [ Static ¥
Tag | Untagged ¢ | Layer | Default &

© Inspector

¥ level-1
Tag | Untagged :| Layer | Default

This should give the following in scene view



Create three more, label them level-2, level-3 and level-4, then move then into the below positions,

it should look like this:

Here are the Inspector Panel transforms

© Inspector | Serviees e

W level-1 | [ Static v
Tag | Untagged ¢ | Layer | Default ™
¥ .~ Transform &,

Position
Rotation
Scale

%0 'y [-20 'z'10 |
X0 Yo 'z[o
x vyl lzk




O Inspector

W level-2

O Inspector

Tag | Untagged

W level-3

Tag | Untagged

| © Inspector

W level-4

Tag | Untagged

Next create 4 new Materials and apply to each level

Assets » Materials

Ivi4Material

LvilMaterial Lvi2Material LvI3Material Lvli4Material
Red 141 42 197 249
Green 101 54 89 0
Blue 242 133 19 0
Alpha 255 255 255 255

After applying the materials to the levels, you should see the following in the scene view



Next we will make the player model, in this case, let’s make a simple cube to move around. In the
hierarchy panel, right click and create 3D Object->Cube. We want the player to not be part of the

Baseland group, so make sure BaselLand is not selected when you create the Cube, if it is, you can
drag the Cube out of the group.

Create cube

=Hierarchy I
| Create *| (oAl )
v € Untitled* -=
Main Camera
Directional Light
¥ BaseLand
level-1
level-2
level-3
level-4

Copy

Paste

Rename

Duplicate

Delete

Select Prefab

Create Empty

3D Object > Cube
2D Object > Sphere
Effects > Capsule

When this is done, you will see the cube appear below the centre of the scene, to fix this reset the
position of the cube, change its name to Player for ease of reference and position the cube just
above and near the back of Baseland .

© Inspector [ Servieas e

& Player | [] static v

Tag | Untagged ¢ | Layer | Default ™

¥ . Transform &,
Position X0 Y 24 ' Z -67.6 |
Rotation X0 'Y 0 1Z/0 |
Scale X|1 Y1 |Z[1 |




Scene view should look like this, remember to rotate the view using alt and mouse down to
scroll/rotate the viewing camera.

Create a new material for the player and apply it. Just to make things a little different, use the
following RGBA settings; R:34, G:34, B:34, A:170 and in the inspector, change the rendering mode to
transparent. Then apply it to the player object.

Assets » Materials

playerColour }

Creates the follow scene view:

Next, we add movement to the Player object. To start with we add a RigidBody to the Player. This
can be done by clicking on Add Component->Physics->RigidBody



A 1l
1V s omponent

Rigidbody 4

From here we add a new script to the player object, in the Assets folder, click into Scripts, then right
click and create new C# Script, call this script playerMovement.

I
Javascript
Shader >
Testing >
Open Scene Additive Playables >
Import New Asset... Scene
Import Package > Prefab
EBxport Package... Audio Mixer
Find References In Scene ~
Select Dependencies
Lens Flare
Refresh Ctri+R Render Texture
Reimport Lightmap Parameters
Reimport All Custom Render Texture
Run AP| Updater... Sprite Atlas
Open C# Project %

Now, double click the script, it should open in visual studio.



?tutorial 2
System.Collections;
System.Collections.Generic;
UnityEngine;

playerMovement : MonoBehaviour {

Start () {

Update () {

As we did in the last tutorial, we need to be able to programmatically access the player object, to do
this we will create a couple of variables above the void start, this will be the speed (used for speed of
movement) and rigidbody (Allow the object to be interacted with).

The code looks like this

playerMovement : MonoBehaviour {

speed;
Rigidbody rb;

() {

Next, we initialise the access to the rigidbody this is done in the start function. We get all of the
components of the rigidbody and make then accessible via the rb variable

() A

rb = GetComponent<Rigidbody>();

Next, we add in the ability to capture the movement via input, i.e. a key is pressed (WASD or Cursor
keys). This is done by creating a couple of float variables called moveHorizontal and moveVertical.



From here, we implement a Vector3 variable (x, y, z). This variable holds the horizontal, vertical and
Y position of the player object.

Finally, we apply force to the rigidbody to make it move when the keys are pushed. The force is
calculated by movement * speed. The code below is what should be created.

O

moveHorizontal = Input.GetAxis(“"Horizontal");

moveVertical = Input.GetAxis("Vertical");

Vector3 movement = Vector3(moveHorizontal, ©.0f, moveVertical);
rb.AddForce(movement * speed);

Notice that the Update function is replaced with the FixedUpdate function.

The overall code for player movement is:
System.Collections;
System.Collections.Generic;
UnityEngine;

playerMovement : MonoBehaviour {
speed;

Rigidbody rb;

01
rb = GetComponent<Rigidbody>();

@)

moveHorizontal = Input.GetAxis("Horizontal™);
moveVertical = Input.GetAxis("Vertical”);

Vector3 movement = Vector3(moveHorizontal, ©.0f, moveVertical);
rb.AddForce (movement * speed);

Save (Ctrl+S or File -> Save), then return to unity.

From here, drag the newly created script from the Assets folder on to the player object, so the script
is linked to the object.



O Inspector

o [Player | [[] static =

Tag | Untagged #] Layer | Defaule A

playerCaolour *
» Shader |Standaed -]

Before we test the code, let’s check what we will see by clicking on the Main Camera in the hierarchy
view. The camera indicates that we won’t see much, as such let’s re-position the camera to see the
player drop onto the Baseland object.

Original View




Changed View

| © Inspector
& Main Camera | [_] Static =
Tag [ MainCamera

Assign the player a base speed (15) and then test, push the play button

This is what happens in the scene




We see the cube fall and by using the keys (WASD or Cursor) we can see the cube bounce and move
around the sphere, the main issue we have is that the camera isn’t following the player, so we have
no way of getting the cube to level 4.

Script 1
To make this happen, we need to create a new script and apply it to the camera.

Right click in the Scripts folder and create a new C# script called chaseCam.

Show in Explorer
Open

Delete

Open Scene Additive

Import New Asset...
Import Package
Export Package...
Find References In Scene Ao Mo
Select Dependencies
Material

Refresh Vst Flare

S Render Texture
Reimport All Lightmap Parameters

Run AP| Updater... Custom Render Texture

Open C# Project S i
Sprites

Animator Controller

Select Main Camera from the hierarchy panel and then drag the chaseCam script into the Inspector
Panel.

tutorial2*




| © Inspector Services - .=
¥ Main Camera || Static =
Tag | MainCamera | Layer | Default &
¥ .~ Transform [T
Position X0 ¥ 6,35 Z|-75.54
Rotation X 23.934 Y0 Z0o
Scale X1 Y1 Z|1
vk ¥ Camera @&
Clear Flags Skybox 4]
Background N ¢
Culling Mask Everything N
Projection Perspective §)
Field of View 60
Clipping Planes MNear 0.3
Far 1000
Viewport Rect X0 Y 0
wi H1
Depth -1
Rendering Path Use Graphics Settings 4]
Target Texture None (Render Texture) o]
Occlusion Culling v
Allow HDR ~4
Allow MSAA (o
Target Display Display 1 N
[= W GUI Layer ﬁ &,
w ¥Flare Layer ﬂ -
¥ Audio Listener [TE=Y
¥ s/ ¥ Chase Cam (Script)

Script

chaseCam

Tl

Add Component

From the inspector panel, we will use the cog to edit the script, this will open the script in visual

studio.

v | ¥ Chase Cam (Script)
Script

chaseCam

Add Component

The initial view is an empty script.

Reset

™

Remove Component
Move Up
Copy Component

Edit Script

conent As |

omponent Values

e

Blpublic class chaseCam : MonoBehaviour {

Start () {

Update () {

To modify this script we need to access some information, we need to tell the camera which game
object it needs to follow, what speed it needs to follow at and then we need to apply a smooth



transition for animation by using the Maths function Lerp. A maths lerp basically alters between the
start and end value of two numbers. When applying this to a position transform it ends up being a
smooth transition.

To start with, we will need to add some variables outside the update function.

chaseCam : MonoBehaviour {

GameObject objectToFollow;
speed = 2.0f;
zOffset 0.2f;
yOffset = 0.08f;

Update () {

The public GameObject will be selectable inside unity.

From here, we need to modify the update function, like this

Update () {
interpolation = speed * Time.deltaTime;
Vector3 position = .transform.position;

position.z = Mathf.Lerp( .transform.position.z - zOffset, objectToFollow.transform.position.z, interpolation);

position.y = Mathf.Lerp( .transform.position.y + yOffset, objectToFollow.transform.position.y, interpolation);

position.x = Mathf.Lerp( .transform.position.x, objectToFollow.transform.position.x, interpolation);
.transform.position = position;

This set of code does all of the calculations required to keep the camera moving behind the player.
The total code looks like this:

System.Collections;
System.Collections.Generic;
UnityEngine;

: MonoBehaviour {

GameObject objectToFollow;
speed = 2.0f;
20ffset = 08.2F;
yOffset = 0.08f;

Update () {
interpolation = speed * Time.deltaTime;

Vector3 position = .transform.position;

position.z = Mathf.Lerp( .transform.position.z - zOffset, objectToFollow.transform.position.z, interpolation);

position.y = Mathf.Lerp( .transform.position.y + yOffset, objectToFollow.transform.position.y, interpolation);

position.x = Mathf.Lerp( .transform.position.x, objectToFollow.transform.position.x, interpolation);
.transform.position = position;

Save this code and then go back to unity.

With the main camera selected, examine the Inspector panel.



Notice we have a default speed, which we can change, and nothing set to follow. To fix this, click on
the target to the right of Object to follow, this will bring up the Select GameObject panel.

Select GameObject ﬂ

From here, click on the scene tab, this will provide a list of objects
to select.

Select GameObject n

From this list of objects in the
game select Player. It will appear
in the Inspector Panel.

None

Nome

Now hit play to test the game.

By using the keys, you should be able to move the player from the green BaseLand object through to
level 4, the red base.



As you can see, the camera follows the player over each of the levels. There are some unique
elements such as the player being able to speed away from the camera, though when we slow down
the camera catches up. This is based off not having limits on the speed the player can get to. Feel
free to play with the settings.



Script 2
There are multiple scripts that can be used when using unity, they all rely upon modifying the state
of the camera. As such, here is another script for a chase cam.

Start a new project and call it CC2.
Add a plane and a sphere to the world.

Right click in the hierarchy and select 3D object->Plane.

= ierarchy S

Select Prefab

Create Empty




Next right click in the hierarchy and add a sphere.

“=rerarcy [

Capsule

In the inspector properties, name the sphere player, ensure it is tagged as player and raise the
sphere’s Y axis so it is above the plane.

© Inspector
Tag (Player ¢/ layer Defaue = ¢]




Create 2 new materials and drag onto the plane and sphere, in this manner we will be able to
distinguish the differences between the objects.

. Folder
C# Script
>

Create

Javascript
Show in Explorer Shader
S Testing
L Playables
per Additiv
Open Scene Additive Scene
Import New Asset... Prefab
Import Package P
Export Package...
Find References In Scene Material
Select Dependencies Lens Fioee
- Render Texture
‘@project  [CICORSOIENI Refresh
| Create - Lightmap Parameters
| - Reimport =
v Qémrlhi Assets » Custom Render Texture o
All Materials Reimport All .
©, All Models : Sprite Atlas
QAII Prefabs Run AP| Updater... Sprites
¥ i Assets Open C# Project Animator Controller
. Animation
W Scripts . L
@1 Project
l Create ~ l
V{}Favorites Assets

@AII Materials
@AII Models
©\ All Prefabs

blue yellow

Once this is done, we need to apply a rigid Body to the Player so it will be able to fall and then the
move code to the player as well.



. This can be done by clicking on Add Component->Physics->RigidBody

Rigidbody

From here we add a new script to the player object, in the Assets folder, click into Scripts, then right
click and create new C# Script, call this script playerMovement.

I
Javascript
Shader >
Testing >
Open Scene Additive Playables >
Import New Asset... Scene
Import Package > Prefab
Export Package... Audio Mixer
Find References In Scene "
Select Dependencies
Lens Flare
Refresh CtrieR Render Texture
Reimport Lightmap Parameters
Reimport All Custom Render Texture
Run API Updater... Sprite Atlas
Open C# Project e

Now, double click the script, it should open in visual studio.



?tutorial 2
System.Collections;
System.Collections.Generic;
UnityEngine;

playerMovement : MonoBehaviour {

Start () {

Update () {

As we did in the last tutorial, we need to be able to programmatically access the player object, to do
this we will create a couple of variables above the void start, this will be the speed (used for speed of
movement) and rigidbody (Allow the object to be interacted with).

The code looks like this

playerMovement : MonoBehaviour {

speed;
Rigidbody rb;

() {

Next, we initialise the access to the rigidbody this is done in the start function. We get all of the
components of the rigidbody and make then accessible via the rb variable

() A

rb = GetComponent<Rigidbody>();

Next, we add in the ability to capture the movement via input, i.e. a key is pressed (WASD or Cursor
keys). This is done by creating a couple of float variables called moveHorizontal and moveVertical.



From here, we implement a Vector3 variable (x, y, z). This variable holds the horizontal, vertical and
Y position of the player object.

Finally, we apply force to the rigidbody to make it move when the keys are pushed. The force is
calculated by movement * speed. The code below is what should be created.

O

moveHorizontal = Input.GetAxis(“"Horizontal");

moveVertical = Input.GetAxis("Vertical");

Vector3 movement = Vector3(moveHorizontal, ©.0f, moveVertical);
rb.AddForce(movement * speed);

Notice that the Update function is replaced with the FixedUpdate function.

The overall code for player movement is:
System.Collections;
System.Collections.Generic;
UnityEngine;

playerMovement : MonoBehaviour {
speed;

Rigidbody rb;

01
rb = GetComponent<Rigidbody>();

@)

moveHorizontal = Input.GetAxis("Horizontal™);
moveVertical = Input.GetAxis("Vertical”);

Vector3 movement = Vector3(moveHorizontal, ©.0f, moveVertical);
rb.AddForce (movement * speed);

Save (Ctrl+S or File -> Save), then return to unity.

Now if we test it, we should be able to see the player drop onto the plane and be moved around by
using the WASD keys.

Now we will create a new scrip to go on the main camera.

Right click in the scripts folder and create a new C# script.



Create Folder

Show in Explorer

C# Script
Shader
Testing

Open

Delete

Call this Script chaseCam

. Favorites Assets
OLAll Materials
{0 All Models
‘O All Prefabs

‘/— .- -
T \ 1T

blue GTETETD playerMov.. yellow

- Assets

Double click the file and open up visual explorer

- *3 camChase
System.Collections;

System.Collections.Generic;
UnityEngine;

camChase : MonoBehaviour {

Change the code in the following manner



lass camChase : MonoBehaviour {

[SerializeField]
- Transform target;

[SerializeField]
orivate Vector3 offsetPosition;

[SerializeField]

private Space offsetPositionSpace = Space.Self;
[SerializeField]

orivate bool lookAt

Side Note: a serialized field makes a private variable accessible in unity, this can be achieved with a
public variable, but it does appear in unity code, hence the introduction to it.

After the variables, add the following:

Refresh();




void Refresh()

if (target == null)

Debug.LogWarning("Missing target ref !", this);

ret

>

if (offsetPositionSpace == Space.Self)
{

transform.position target.TransformPoint(offsetPosition);

transform.position target.position + offsetPosition;

—

f (lookAt)

-

transform.LookAt(target);

transform.rotation = target.rotation;

Ensure you do not miss the closing } curly brace.
Save and go back to unity.

Once in unity, highlight the main camera in the hierarchy panel and then in the inspector panel , add
the camChase script.

Add Component J
al )
< Scripts

UnityEngine .EventSystems >

Cam Chase

(| Player Movement

Once the script has been added, you will need to set the properties. In the inspector.



Original

v || ¥ Cam Chase (Script) &,
Script .~ camChase o)
Target ‘None (Transform) | ®
Offset Position X0 Yo |Z|o |
Offset Position Space | Self : |
Look At 4

Modified

v/ ¥ Cam Chase (Script) &,
Script - camChase ©
Target ' A Player (Transform) ]
Offset Position X0 1¥|1 |z-3 ]
Offset Position Space | world s )
Look At 4

Save and test.

The camera will position itself behind the player and when you move the player, the camera will
follow as well.






