Game Design — Unity Workshop
Activity 3

Goals:

- Creation of small world
- Creation of character
- Scripting of player movement and camera following

Load up unity

. Unity 2017.1.0p5 (64-bit)
E Report a Problem with Unity
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Build Object: Scene Swapping and Menu Creation

Aim: Create multiple scenes and swap between them, i.e. menu systems

To start with right click in the hierarchy and create a Panel, this is done via the Ul element.



When the panel is created you will see that it adds an Event System and Canvas. The Canvas is
designed to hold all elements of the User Interface.

¥ € Untitled*

On the Inspector, the Panel has a lot of elements such as Anchors. Anchors a re a way of holding the
elements inside the panel, the easiest way to set up the screen is to set the anchors and then,
change the Left, Top, Right and bottom values.

@ Inspector  ISENEEEIIII————
o [Panel ] [ static ¥
Tag|Untagged ~ #|layerfur 3]

Change from 3D to 2D to be able to see the scene easier. Click on 2D.



# Scene
| Shaded *||2D || % | <) | &I

Next change, the Anchors min max values respectively to X 0.25 & 0.75 and Y’s values to 0.2 & 0.8.
Once that is done, you should see the following.

| @ Inspector [ SERESSIIIIEes
¥ Panel | ] Static
Tag | Untagged 4| Layer | UI $.]
¥ Rect Transform &+,
custom Left Top Pos Z
£ [-328 125 o |
& | Right Bottom
v 1-328 -125 | i LR
¥ Anchors
Min X10.25 ¥ |0.2
Max X10.75 Y 0.B
Pivot %[0.5 y[0.5

From here zero out the Left, Top, Right and Bottom values. Also, change the name of the panel to
MainMenuPanel. Then scroll to examine the scene.

© Inspector  [ISERIEESI———
& |MainMenuPanel | [] static *

Tag | Untagged 4| Layer [UI +/| These values centre the panel into the
¥_. RectTransform [@ #| screen, as can be viewed below. The
. =it I:‘& ”1;“ ":“ z | white box is the viewing area.
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¥ Anchors

Min x[0.25 Y[0.z

Max X 0.75 Y08

Pivot x[0.5 Y05
Rotation x[0 Yo z/o
Scale X[1 ¥[1 z[1




On our Menu system we will have three buttons, Start Game, Help and Quit. To start with, right click
on the hierarchy panel and create a button as a child to the MainMenu Panel.

Once created, give this first button a name such as StartButton, in the Inspector panel.

© Inspector

. ¥ [StartButton
Tag|Untagged  ¢|Layer [uI

startButton

Notice in the Scene view that the button has the text of button on it.

To change this, go through the hierarchy panel to get to the text element of the button.




From the inspector panel, you can change the text, font style, font size and how text acts. In this
case change the text from button to Start Game, increase the font to 20 and change both vertical
and horizontal overflows to overflow.

o [Text ] O static »
T“M“T“u

When you look at the scene view, the button is
centred on the layout and the text fills the scene.

Next, we want to create the other two buttons, we
could create a new button and go through the same
steps, but then we would be dealing with the
alignment of the buttons. The best thing to do is to add a vertical layout group to the
MainMenuPanel. Click on MainMenuPanel on the hierarchy and then add the new component to the
inspector for it.

To locate use the search capability.

Elvertical Layout Group

l

This automatically puts the button in the top left corner of the panel, which is not what we want to
do, as such, we can make adjustments to the Vertical Layout Group to position it.




v =l ¥ vertical Layout Group (Script) &,
b Padding

Spacing 0 ]
Child Alignment | Upper Left $
Child Controls Size || Width | | Height
Child Force Expand v Width | Height
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The changes are from the drop down menu, change it to upper center and add a top padding of 90.

v = ¥ Vertical Layout Group (Script) &,
¥ Padding
Left 0 |
Right 0 ]
Top |90 |
Bottom 0 ]
Spacing 0 |
Child Alignment | Upper Center : |
Child Controls Size || Width |_| Height
Child Force Expand W Width |« Height

This produces the following

Start Game




Next we can copy and paste the StartButton object and rename them to Help and Quit. Also change
the text of each button to match what it does.

v Cll‘l't.ll ¥ 716 Text (Scrip)
¥ MainMenuPanel Text
b StartButton Help
¥ HelpButton
Text
¥ QuitButton Character
Text Font | 4 Arial
EventSystem Font Style | Mormal

This should produce the following

Next, we have to save the scene so that we can access it. Go to the menu, click File -> Save Scenes

File Edit Assets GameObject Compon

New Scene €N ¢ Create a folder in the Assets folder called scenes and save
Open Scene Chis0 this scene as MainMenu.
Save Scenes Ctrl+S

= You should end up with the following.
Save Scene as... Ctrl+Shift+S



Now go to the Menu and go to Build-> Settings

éﬁmameobjen Componen

New Scene Ctrl+N
Open Scene Ctrl+0
Save Scenes Ctrl+S
Save Scene as... Ctrl+Shift+S
New Project...

Open Project...

Save Project

This create the following pop-up that will let us link our scenes.

Build Settings x

From here click Add Open Scenes, you should see the following appear:




Now that this is listed, note that is has a number of 0 next to it. Next Go File -> New Scene

File Edit Assets GameObject Component

M &“ Ctl’l-l-N Cents
Open Scene Ctrl+0O

In this scene, switch back to 3D view by click on the 2D icon

# Scene

Shaded

Add a plane and a cube to it. Raise the cube above the plane and apply a rigidbody to the cube, so
that when the game runs, the cube will drop to the plane.

From here go to the menu and do File->Save Scene As. This way you save the scene into the scenes
folder.

€ Unity 2017.3.1f1 Personal (64bit) - Untitled

. File Edit Assets GameObject Compo
| ]

New Scene Ctrl+N
Open Scene Ctrl+0 Name this scene level-1.
Save Scenes Ctrl+S

Save Scene as... Ctrl+Shift+S
You should see the following.

New Project...



Once again, go in to build settings and add the open scene.

Notice, that level-1 has the index number of 1. This will come in useful for the code we are going to
apply to the start game button.

Now open up the Main menu scene by double clicking on it in the assets folder.

Change back to 2D view, click on Canvas and centre it on the scene so you can se what you are
doing.

From here, click on the StartButton and add a new script to it.



i Q. LoadNewScenel o

Search By putting in an unknown name in the search bar, the add
components will automatically figure out that you want a
new script by that name, click on new script and then create

. and add.
- [arTrrr—
4 New Script =
I Name =
[Coadnewscene = Inthe assets folder create a new
Language (csharp_:) folder called scripts and then

- dragthe new script file into it.

\ Add Component

l ( Create and Add J

\ Add Component J

@ Project - [ Console

Create ~

¥ . Favorites Assets » Scripts

. All Materials
O All Models
" All Prefabs =
- 1T
¥ Ll Assets
& Scenes LoadNewSc..
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From here load up the script in an editor. And enter the following code.

System.Collections;
System.Collections.Generic;
UnityEngine;

s UnityEngine.SceneManagement;

lass LoadNewScene : MonoBehaviour {

void LoadByIndex(int sceneIndex)

SceneManager.LoadScene(scenelndex);

Notice the Using line to be added. Once done, save and go back to unity.

Withteh start button clicked, you should see the following



On Click ()
List is Empty

Default UI Material &,

As this is a button we need to add a click event, this event is going to be the script we just wrote, to
start with click on the + symbol in the onClick section. You should see the following.

From here we need to be able to offer the scene we want to move too, this is done by selecting the
function from the script via the drop down menu. So, click on No Function -> LoadNewScene-
>LoadByIndex



== o Click (
e B 0
|- StartButton (Lo. O} '/ No Function
GameObject >
V Lend Scen RectTransform >
Script ﬁ (]
CanvasRenderer >
Default UI Matx msge ~ &,
> Shader | Ul/Defa e 3 .
bool enabled I LoadNewScene >
string name
bool runinEditMode
string tag
bool useGUILayout
BroadcastMessage (string)
Cancellnvoke (string)
Cancellnvoke ()
LoadByIndex (int)

This changes the on click area to this:

on Click ()

Runtime Onl

-l f MM e Mo _:_an ] e

As you can see the parameter it is set to is 0, if you recall from here, we want to click and go to the
level-1 scene, it’s index number was 1 which was located in the build settings.

So, change the 0 to a 1 and then run it and test the click.

On Click ()

Runtime Onl LoadMNewScene.LoadByIndex

 StartButton (Lo ©}|1

This should transition between the MainMenu scene and Level-1 scene.

Now that this is working, we will look at the help menu item.



In the hierarchy panel, click on the ManMenuPanel and Duplicate it.

- MainMenu*

MainMenuP ag

MainMenuPanel (1)

You should see the following.

Now, with the Second panel delete the StartButton
and HelpButtons. Rename the Panel to Help Panel.
Rename the QuitButton to BackButton.

If the word Back is raised from the button, go into
the text settings on inspector and change the
overflow settings.




To hide the MainMenuPanel, turn off the active next to it’s name.

© Inspector
' [ ‘MainMenuPanel | [_] Static ¥
Tag M Layer “ 'I

Now, back to the back button, next we are going to add some text. In the hierarchy panel, click on
help button and then right click, go to Ul->Text

You should see the following

Duplicate
Delete

Select Prefab

Create Empty
3D Object

2D Object
Effects
Light
Audio

This will correct the alighment and centre the text on the
scene.

Go into the text settings and add some lorem ipsum text. You should end up with something like
this:




Now that the content has been taken care of we will get the button to work. This will be done within
unity by swapping the active state of the panels.

On the help panel, make it non-active and make MainMenuPanel active.

J Helppanet
lii".r.ilLJiﬂI.IIldIIIIIIIIIIIIIIIIIIIII.J ijrnr LJ‘LI.I...

© nspecior R
. ¥ MainMenuPanel J
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Once this is done one MainMenuPanel, click on the help Button

In the inspector panel we have the Onclick area.

' on Click ()

List is Empty

HelpButton

Click the + symbol.

Click on the target icon next to the object, then select the helpPanel



Select Object

@

From here we are going to use the No Functions drop down and
change the setActive option.

What we are after is When we click on the help button, we want
the HelpPanel to become active, i.e. shown to the end user and
the MainmenuPanel to become inactive.

To achieve this add the setActive(bool) setting.

LT Sl

Lm-ﬂ - No Function

bool isStatic

int layer RectTransform >
string name CanvasRenderer >
string tag Image >
BroadcastMessage (string) VerticalLayoutGroup >

SendMessage (string)
SendMessagelpwards (string)

This provides the following:

If the checkbox is not ticked, it means false, i.e. do not setActive. In this case, we want to add a tick,
as when we click on the help button we want to see the help panel appear.

Once you have done that, add the MainMenuPanel to the on click section and set it as not active.
You should end up with the on click section looking like this:



On Click ()

| Runtime Only  #|| GameObject.SetActive %]
I_Iﬁm_l_ll

Run the program and test it.

This should give you a working menu to the help system. Now, repeat the same steps on the back
button in the HelpPanel.

Your Back Button should end up with this:

On Click ()
| Runtime Only ¢ || GameObject.SetActive %]

HelpPane

Which is the opposite of the helpButton. Run and test it.

Finally, we need to add the quit functionality to the menu system.
Click on the Quit Button in the hierarchy.

Then in the add Component section, do a search on QuitGameClick; create the new script and go to

the code.
_ Once you have done this, drag the

< New Script new script into the scripts folder and
open up the script to code.

- vyee

Assets » Scripts




class QuitGameClick : MonoBehaviour {

#1if UNITY_EDITOR
UnityEditor.EditorApplication.isPlaying = false;

>
#else

Application.Quit ();
#endif

Notice this has the effect of quitting the game once it is used externally of the unity editor and of
exiting the unity editor.

Once you have saved this script, we need to assign it to the button onclick event, as we did with the
scene manager.

The inspector of quit button should have the following:

On Click ()

| Runtime Only ¢ || QuitGameClick.Quit

& QuitButton (Qui O]

ar
e

v ¢ Quit Game Click (Script) (WE-
Script QuitGamecClick o)




Test as Game

< Unity 2017.3.1f1 Personal (64bit) - MainMent
[ File Edit Assets GameObject Compones

Ctri+N

To test as an actual game go to the menu and do File-
>Build & Run

New Scene

Ce¢ Give the exe a name and save to a location you can find,
Open Scene Ctri+0 in this case, I'll use the desktop.
Save Scenes Ctrl+S L | < Buid Windows "
Save Scene as... Ctrl+ShiftsS oy © T T beeed |8 [ 2
Organise »  New folder =y @
New pgojmm P A Name Date modified Type
. [ Deskio, * No items match your search
Open Project... : o
Save Project 2 :‘““’“““ ‘
&= Pictures *
o > < . OneDrive
Build Settings..  Ctr+Shift+B | =7
2| 2017 Pay details
Build & Run Crl+B & Coding Erample 5
- File name: | Pl "
Save as type: | exe v
~ Hide Folders Concel

Once it has been built, there should be a configuration window popping open, select the defaults
and click play! To test it.

Tutorial 7 Configuration X

Graphics Input

Screen resolution

3840 x 2160 v [Jwindowed

Graphics quality

Select monitor

Display 1 (Left) &4

| Play! ‘ |

Quit




